User Tools

Site Tools


Sidebar

luarocks:pg

Q. While installing the pg module using luarocks I get the following error:

CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 (message):

Could NOT find TARANTOOL (missing: TARANTOOL_INCLUDE_DIR)

Call Stack (most recent call first):

/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
cmake/FindTarantool.cmake:26 (find_package_handle_standard_args)
CMakeLists.txt:11 (find_package)

-- Configuring incomplete, errors occurred!
See also "/tmp/luarocks_pg-scm-1-1289/pg/CMakeFiles/CMakeOutput.log". 

How do I fix it? (2017)

A. You need to install the tarantool-dev package.

Also, this might come in handy: https://tarantool.org/en/doc/1.7/reference/reference_rock/dbms.html.

Comments

Enter your comment. Wiki syntax is allowed:
S A R S O
 
luarocks/pg.txt · Last modified: 2018/05/25 18:01 by eabates

Real Time Web Analytics